スポンサーサイト

一定期間更新がないため広告を表示しています

| - | | - | - |
rubyとgemのインストール
sudo apt-get install zlib1g-dev
sudo apt-get install libssl-dev

# wget ruby http://www.ruby-lang.org/ja/downloads/
./configure --prefix=/usr/local --enable-pthread --enable-shared
make
sudo make install

cd ext/openssl
ruby extconf.rb
make
sudo make install

# wget http://production.cf.rubygems.org/rubygems/rubygems-1.3.7.tgz
sudo ruby setup.rb

ソースコードから入れる理由はacp.vimのためだけ。
CENTOSの場合は公式で提供されているrubyのバージョンが終わっているので上記手順必須。

ちなみに1.9系のrubyはgemが一緒にインストールされることを最近知った。
ディストリビューションはDebianです。

| Jekyll | 01:14 | comments(0) | - |
スポンサーサイト
| - | 01:14 | - | - |









     12
3456789
10111213141516
17181920212223
24252627282930
<< September 2017 >>
+ NEW ENTRIES
+ CATEGORIES
+ ARCHIVES
+ PROFILE
+ OTHERS
SPONSORED LINKS
このページの先頭へ